ruby

An Interpreted Object-Oriented Scripting Language

Ruby is an interpreted scripting language for quick and easy object-oriented programming. It has many features for processing text files and performing system management tasks (as in Perl). It is simple, straight-forward, and extensible. * Ruby features: - Simple Syntax - *Normal* Object-Oriented features (class, method calls, for example) - *Advanced* Object-Oriented features(Mix-in, Singleton-method, for example) - Operator Overloading - Exception Handling - Iterators and Closures - Garbage Collection - Dynamic Loading of Object Files (on some architectures) - Highly Portable (works on many UNIX machines; DOS, Windows, Mac, BeOS, and more)

  • รุ่น 2.5
  • Size 11.5 กิโลไบต์
  • openSUSE Tumbleweed
Direct Install

Distributions

openSUSE Tumbleweed

official release Official
2.5

OBS:Server:Unstable Experimental
2.3
1 Click Install
devel:languages:ruby Experimental
2.5
home:enavarro_suse ชุมชน
2.4
home:loosi ชุมชน
2.1.5
1 Click Install

openSUSE Leap 15.0

official release Official
2.5

2.5.0
1 Click Install
home:aevseev ชุมชน
2.4.4
1 Click Install

openSUSE Leap 42.3

official release Official
2.1

2.5.0
1 Click Install
home:aduffeck ชุมชน
2.4.1
1 Click Install
home:aevseev ชุมชน
2.4.4
1 Click Install

SUSE SLE-15

2.5.0
1 Click Install

SUSE SLE-11 SP 4

OBS:Server:2.7 Experimental
2.3
1 Click Install
1.8.7.p357
2.2
1 Click Install
2.1

Debian 8.0

home:2pitsin ชุมชน
2.2.2

Debian 7.0

home:2pitsin ชุมชน
2.2.2

ScientificLinux 6

home:takehironet ชุมชน
2.4.3

RedHat RHEL-7

2.0.0.353
home:fusion809 ชุมชน
2.0.0.598
2.0.0.353

RedHat RHEL-6

home:fusion809 ชุมชน
2.0.0.598

CentOS CentOS-7

2.4.1
home:aevseev ชุมชน
2.4.4
home:k0da:rh-obs ชุมชน
2.3
home:takehironet ชุมชน
2.5.0

CentOS CentOS-6

home:aevseev ชุมชน
2.4.4
home:takehironet ชุมชน
2.4.3

Ubuntu 14.04

YaST:SLE-12:GA:Travis Experimental
2.1.0.0~ubuntu3
home:2pitsin ชุมชน
2.2.2

Ubuntu 12.04

YaST:SLE-12:GA:Travis Experimental
2.1.0.0~ubuntu3
YaST:SLE-12:SP1:Travis Experimental
2.1.0.0~ubuntu3
YaST:SLE-12:SP2:Travis Experimental
2.1.0.0~ubuntu3
2.1.0.0~ubuntu3
2.1.0.0~ubuntu3

Unsupported distributions

The following distributions are not officially supported. Use these packages at your own risk.

openSUSE:13.2

2.0
2.3
2.1
2.1

openSUSE:Leap:42.1

2.3
2.1
2.2
1.9.3
2.1

openSUSE:Leap:42.2

2.4.1
2.2
2.1.5
2.1

openSUSE:13.1

2.0
2.1
2.1
2.0

openSUSE:12.2

1.9.3
2.0
1.9.3
1.9.3

openSUSE:12.3

2.0
1.9.3
1.9.3

openSUSE:11.4

2.1.2
1.9.3
1.8.7.p334
1.8.7.p357
1.8.7.p357
1.8.7.p357

openSUSE:12.1

1.9.3
1.9.3
1.8.7.p352
1.8.7.p357

DISCONTINUED:openSUSE:11.2

1.8.7.p357
1.8.7.p357

openSUSE:11.3

1.8.7.p249

DISCONTINUED:openSUSE:11.1

1.8.7.p249
1.8.7.p249

openSUSE:11.1

1.8.7.p72

openSUSE:11.2

1.8.7.p72

SUSE:SLE-12:SLE-Module-Toolchain

2.3
2.1
2.0.0.353

SUSE:SLE-11:SP3

1.9.3
2.0
2.1

SUSE:SLE-11:SP2

1.9.3
2.1.2
1.9.3

Intel:Moblin2

1.8.6.287

Fedora:25

2.2.7
2.2.7

SUSE:SLE-11

SUSE:SLE-11:SP1

SUSE:SLE-10

1.8.7.p357