ruby

An Interpreted Object-Oriented Scripting Language

Ruby is an interpreted scripting language for quick and easy object-oriented programming. It has many features for processing text files and performing system management tasks (as in Perl). It is simple, straight-forward, and extensible. * Ruby features: - Simple Syntax - *Normal* Object-Oriented features (class, method calls, for example) - *Advanced* Object-Oriented features(Mix-in, Singleton-method, for example) - Operator Overloading - Exception Handling - Iterators and Closures - Garbage Collection - Dynamic Loading of Object Files (on some architectures) - Highly Portable (works on many UNIX machines; DOS, Windows, Mac, BeOS, and more)

  • Version 2.5
  • Größe 11,5 KB
  • openSUSE Tumbleweed
Direkte Installation

Distributionen

openSUSE Tumbleweed

openSUSE Leap 15.0

home:aevseev Community
2.4.4

openSUSE Leap 42.3

home:aduffeck Community
2.4.1
home:aevseev Community
2.4.4

SUSE SLE-15

SUSE SLE-11 SP 4

Debian 8.0

home:2pitsin Community
2.2.2

Debian 7.0

home:2pitsin Community
2.2.2

ScientificLinux 6

home:takehironet Community
2.4.3

RedHat RHEL-7

2.0.0.353
home:fusion809 Community
2.0.0.598
2.0.0.353

RedHat RHEL-6

home:fusion809 Community
2.0.0.598

CentOS CentOS-7

2.4.1
home:aevseev Community
2.4.4
home:k0da:rh-obs Community
2.3
home:takehironet Community
2.5.0

CentOS CentOS-6

home:aevseev Community
2.4.4
home:takehironet Community
2.4.3

Ubuntu 14.04

YaST:SLE-12:GA:Travis Versuchsweise
2.1.0.0~ubuntu3
home:2pitsin Community
2.2.2

Ubuntu 12.04

YaST:SLE-12:GA:Travis Versuchsweise
2.1.0.0~ubuntu3
YaST:SLE-12:SP1:Travis Versuchsweise
2.1.0.0~ubuntu3
YaST:SLE-12:SP2:Travis Versuchsweise
2.1.0.0~ubuntu3
2.1.0.0~ubuntu3
2.1.0.0~ubuntu3

Nicht unterstützte Distributionen

Die folgenden Distributionen werden offiziell nicht unterstützt. Benutzen Sie diese Pakete auf eigene Gefahr.

openSUSE:13.2

2.0
2.3

openSUSE:Leap:42.1

2.3
2.1
2.2

openSUSE:Leap:42.2

2.4.1
2.2
2.1.5

openSUSE:13.1

2.0
2.1

openSUSE:12.2

1.9.3
2.0

openSUSE:12.3

2.0

openSUSE:11.4

2.1.2
1.9.3
1.8.7.p357
1.8.7.p357

openSUSE:12.1

1.9.3
1.9.3
1.8.7.p357

DISCONTINUED:openSUSE:11.2

1.8.7.p357

openSUSE:11.3

DISCONTINUED:openSUSE:11.1

1.8.7.p249

openSUSE:11.1

openSUSE:11.2

SUSE:SLE-12:SLE-Module-Toolchain

2.3
2.1

SUSE:SLE-11:SP3

1.9.3
2.0
2.1

SUSE:SLE-11:SP2

1.9.3
2.1.2
1.9.3

Intel:Moblin2

1.8.6.287

Fedora:25

2.2.7
2.2.7

SUSE:SLE-11

SUSE:SLE-11:SP1

SUSE:SLE-10

1.8.7.p357