texlive

The TeXLive Formatting System

After installing texlive and the package texlive-latex, find a large selection of documentation for TeX, LaTeX, and various layout styles in /usr/share/texmf/doc. TeX (pronounced tech) is an interpreter for text formatting and was developed by Donald E. Knuth. It works with control and macro commands on a text file. Working with TeX is similar to typesetting methods. LaTeX is a complex macro package that removes the cryptical TeX interface and does most of the work for the user. TeX uses special fonts produced by the MetaFont program. Various printer drivers and an X11 viewer are also included in this package. The teTeX package is based on the standard TeX package of Karl Berry, which makes configuration much easier. It is also possible to use PostScript fonts. A real PostScript printer is required, however. If the ghostscript (gs) package is installed, all drivers for printing and viewing can use these fonts. Note, however, that the fonts included in the ghostscript package are not identical to Adobe's PostScript fonts. The copyright prohibids us to include them on the CD. Besides these features, the programs MakeIndex (for producing indexes) and BibTeX (for literature data processing) exist. The texlive package includes a full texmf tree, many programs like tex, dvips, etc., shell script configuration, and a big collection of documentations. This package is easily configured by the script texconfig and has multilanguage options.

  • Version 2019.20190407
  • Size 23.5 KB
  • openSUSE Tumbleweed
Direct Install

Distributions

openSUSE Tumbleweed

official release Official
2019.20190407

openSUSE Leap 15.1

official release Official
2017.20170520

Publishing:TeXLive Experimental
2019.20190407

openSUSE Leap 15.0

official update Official
2017.20170520

Publishing:TeXLive Experimental
2019.20190407
2017.20170520

SUSE SLE-15

2017.20170520

ScientificLinux 7

2012

RedHat RHEL-7

home:ods:ppc64 Community
2012

Ubuntu 16.04

2015.20160320

Ubuntu 14.04

2015.20160320

Ubuntu 12.04

2015.20160320

Unsupported distributions

The following distributions are not officially supported. Use these packages at your own risk.

openSUSE:Leap:15.2

2017.20170520

openSUSE:Leap:42.3

2019.20190407
2016.20160523
2016.20160523

openSUSE:Leap:42.2

2015.20150521

openSUSE:13.1

2013.20130620
2013.20130620

openSUSE:13.2

2013.20130620

openSUSE:Leap:42.1

2013.20130620

openSUSE:12.3

2012.20120611
2012.20120611

openSUSE:12.1

2011

openSUSE:12.2

2011
2011

openSUSE:11.4

2010

openSUSE:11.3

2009

openSUSE:11.2

openSUSE:11.1

2007

Intel:Moblin2

SUSE:SLE-12:SLE-Module-Toolchain

2013.20130620