perl-IPC-ShareLite

Lightweight interface to shared memory

IPC::ShareLite provides a simple interface to shared memory, allowing data to be efficiently communicated between processes. Your operating system must support SysV IPC (shared memory and semaphores) in order to use this module. IPC::ShareLite provides an abstraction of the shared memory and semaphore facilities of SysV IPC, allowing the storage of arbitrarily large data; the module automatically acquires and removes shared memory segments as needed. Storage and retrieval of data is atomic, and locking functions are provided for higher-level synchronization. In many respects, this module is similar to IPC::Shareable. However, IPC::ShareLite does not provide a tied interface, does not (automatically) allow the storage of variables, and is written in C for additional speed. Construct an IPC::ShareLite object by calling its constructor: my $share = IPC::ShareLite->new( -key => 1971, -create => 'yes', -destroy => 'no' ) or die $!; Once an instance has been created, data can be written to shared memory by calling the store() method: $share->store("This is going in shared memory"); Retrieve the data by calling the fetch() method: my $str = $share->fetch(); The store() and fetch() methods are atomic; any processes attempting to read or write to the memory are blocked until these calls finish. However, in certain situations, you'll want to perform multiple operations atomically. Advisory locking methods are available for this purpose. An exclusive lock is obtained by calling the lock() method: $share->lock(); Happily, the lock() method also accepts all of the flags recognized by the flock() system call. So, for example, you can obtain a shared lock like this: $share->lock( LOCK_SH ); Or, you can make either type of lock non-blocking: $share->lock( LOCK_EX|LOCK_NB ); Release the lock by calling the unlock() method: $share->unlock;

There is no official package available for openSUSE Leap 15.4

Distributions

openSUSE Tumbleweed

openSUSE Leap 15.4

openSUSE Leap 15.2

SUSE SLE-15-SP2

SUSE SLE-15-SP1

SUSE SLE-12-SP5

SUSE SLE-11 SP 4

RedHat RHEL-7

RedHat RHEL-5

Unsupported distributions

The following distributions are not officially supported. Use these packages at your own risk.

SUSE:SLE-15:GA

openSUSE:13.2

openSUSE:Leap:42.1

openSUSE:Leap:15.0

openSUSE:Leap:15.1

openSUSE:Leap:42.2

openSUSE:Leap:42.3

SUSE:SLE-12:SLE-Module-Adv-Systems-Management

CentOS:CentOS-5

SUSE:SLE-11

SUSE:SLE-10

deleted

SUSE:SLE-12:GA

openSUSE:11.4

openSUSE:13.1