libzypp

Library for package, patch, pattern and product management

libzypp is the package management library that powers applications like YaST, zypper and the openSUSE/SLE implementation of PackageKit. libzypp provides functionality for a package manager: * An API for package repository management, supporting most common repository metadata formats and signed repositories. * An API for solving packages, products, patterns and patches (installation, removal, update and distribution upgrade operations) dependencies, with additional features like locking. * An API for commiting the transaction to the system over a rpm target. Supporting deltarpm calculation, media changing and installation order calculation. * An API for browsing available and installed software, with some facilities for programs with an user interface.

  • Version 17.24.1
  • Size 2.09 MB
  • openSUSE Leap 15.2
Direct Install Expert Download

Distributions

openSUSE Tumbleweed

openSUSE Leap 15.2

openSUSE Leap 15.1

Fedora Rawhide (unstable)

CentOS CentOS-7

CentOS CentOS-6

home:aevseev Community
16.17.20

Unsupported distributions

The following distributions are not officially supported. Use these packages at your own risk.

openSUSE:Leap:15.0

openSUSE:Leap:42.3

openSUSE:Leap:42.2

openSUSE:Leap:42.1

openSUSE:13.2

openSUSE:13.1

openSUSE:12.3

openSUSE:12.2

openSUSE:12.1

openSUSE:11.4

openSUSE:11.3

openSUSE:11.1

Ubuntu:12.04

SUSE:SLE-12:SLE-Module-Toolchain

SUSE:SLE-10:SP2

SUSE:SLE-10:SP3

SUSE:SLE-10:SP4

DISCONTINUED:openSUSE:11.1

home:coolo:carwos

Fedora:25

Fedora:26