liboop4

Low-Level Event Loop Management Library

Liboop is a low-level event loop management library for POSIX-based operating systems. It supports the development of modular, multiplexed applications that may respond to events from several sources. It replaces the "select() loop" and allows the registration of event handlers for file and network I/O, timers, and signals. Because processes use these mechanisms for almost all external communication, liboop can be used as the basis for almost any application.

  • Version 1.0.1
  • Size 31.1 KB
  • openSUSE Leap 15.2
Direct Install Expert Download

Distributions

openSUSE Tumbleweed

openSUSE Leap 15.2

openSUSE Leap 15.1

SUSE SLE-15-SP2

SUSE SLE-15-SP1

SUSE SLE-15

Unsupported distributions

The following distributions are not officially supported. Use these packages at your own risk.