kdelibs4support

Code and utilities to ease the transition to KDE Frameworks 5

This package includes CMake macros and C++ classes whose functionality has been replaced by code in CMake, Qt and other frameworks. Code should aim to port away from this framework eventually. The API documentation of the classes in this framework and the notes at <<a href="https://community.kde.org/Frameworks/Porting_Notes>">https://community.kde.org/Frameworks/Porting_Notes></a> should help with this. Note that some of the classes in this framework, especially KStandardDirs, may not work correctly unless any libraries and other software using the KDE4 Support framework are installed to the same location as KDELibs4Support, although it may be sufficient to set the KDEDIRS environment variable correctly.

There is no official package available for openSUSE Leap 15.4

Distributions

openSUSE Tumbleweed

openSUSE Leap 15.4

openSUSE Leap 15.3

openSUSE Leap 15.2

SUSE SLE-15-SP1

Unsupported distributions

The following distributions are not officially supported. Use these packages at your own risk.

SUSE:SLE-15:GA

openSUSE:Leap:15.1

openSUSE:Leap:15.0

openSUSE:Leap:42.3

SUSE:SLE-12:SLE-Module-Toolchain

openSUSE:Leap:42.2

openSUSE:Leap:42.1

openSUSE:13.2

SUSE:SLE-12:GA

deleted