aria2fe

Graphical User Interface for the aria2 Metalink Downloader

"aria2fe" (the "fe" stands for "FrontEnd") is a graphical user interface (GUI) for the command line (CLI) based program aria2. aria2fe was designed and constructed using C++/Qt for the GNU Unix/Posix/Linux platform. Essentially, the purpose of aria2fe is to construct the aria2 command line syntax and arguments from a point and click environment and to launch aria2 via xterm. Download progress monitoring is done through xterm acting as a console for aria2fe. In fact, once aria2 has been started, aria2fe can be closed which will free up the system resources (physical memory) allocated to it. xterm will continue its role as console until the download is complete. Depending upon the type of download being done the command line for aria2 can become quite long and complex. Given that, the chance for errors (typos and incorrect arguments) increases dramatically. aria2fe diminishes the chance for errors by delivering a syntactically correct command line each and every time. Furthermore, the ability to "visualize" the command line being constructed aids the user in argument selection. Additionally, command line configurations can be saved to a "conf" file and reloaded for future use. There is no limit to the number of conf files a user may have at any one given time and a browse dialog expedites the finding and loading process for saved configurations. aria2 is a high-speed download utility with resuming and segmented downloading. Supported protocols are HTTP/HTTPS/FTP and BitTorrent. It also supports Metalink version 3.0. As of 0.10.0 aria2 supports chunk checksums in Metalink. It validates chunk checksums while downloading files like BitTorrents. This provides a safer and more reliable download experience. It is being actively developed by Tatsuhiro Tsujikawa.

There is no official package available for openSUSE Leap 15.1

Distributions

openSUSE Tumbleweed

openSUSE Leap 15.2

openSUSE Leap 15.1

SUSE SLE-11 SP 4

Unsupported distributions

The following distributions are not officially supported. Use these packages at your own risk.

SUSE:SLE-12:SLE-Module-Adv-Systems-Management

openSUSE:Leap:15.0