Install package Maemo:Mer:Devel:Apps / midori

No data for Maemo:Mer:Devel:Apps / midori